VLANY v Cisco Packet Tracer

Navrhnite sieť

Urobte konfiguráciu na Switchi. Musíte pomenovať VLANY. V mojom prípade som urobil 2 oddelenia. Jedno sa volá HR a druhé IT

Switch#config terminal
Switch(config)#vlan 10
Switch(config-vlan)#name HR
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name IT

Switch>enable
Switch#config terminal

Switch(config)#int fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Switch(config-if)#int fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Switch(config-if)#int fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

Switch(config-if)#int fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

Switch(config-if)#int range fa0/1-4
Switch(config-if-range)#switchport mode access

Switch(config)#int fa 0/5
Switch(config-if)#switchport mode trunk

Nakonfigurujte Router

Router>enable
Router#config terminal

Router(config)#int fa0/0
Router(config-if)#no shutdown

Router(config-if)#int fa0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip add 192.168.1.1 255.255.255.0
Router(config-subif)#

Router(config-subif)#int fa0/0.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip add 192.168.2.1 255.255.255.0

Teraz prideľte manuálne IP adresy počítačom vo VLANE 10

  • PC 0: 192.168.1.10
  • PC 1: 192.168. 1.20
  • Gateway: 192.168.1.1

Teraz prideľte manuálne IP adresy počítačom vo VLANE 20

  • PC 2: 192.168.2.10
  • PC 3: 192.168.2.20
  • Gateway: 192.168.2.1

Urobte ping z PC 2 na PC4

ping 192.168.2.20

Obrázok znázorňuje úspešnú komunikáciu medzi počítačmi

VPN Cisco Packet tracer

Navrhnite si sieť

Na konfiguráciu budete potrebovať Router 1841

Na r1 routri urobte konfiguráciu

Router>enable
Router#config t
Router(config)#host r1
r1(config)#int fa0/0
r1(config-if)#ip add 192.168.1.1 255.255.255.0 
r1(config-if)#no shut
r1(config-if)#exit
r1(config)#int fa0/1
r1(config-if)#ip address 1.0.0.1 255.0.0.0
r1(config-if)#no shut

Teraz urobte defaultné smerovanie

ip route 0.0.0.0 0.0.0.0 1.0.0.2

Na r2 routri

Router>enable
Router#config t
Router(config)#host r2
r2(config)#int fa0/0
r2(config-if)#ip add 1.0.0.2 255.0.0.0
r2(config-if)#no shut
r2(config-if)#exit
r2(config)#int fa0/1
r2(config-if)#ip add 2.0.0.1 255.0.0.0
r2(config-if)#no shut

Na R3 routri

Router>enable
Router#config t
Router(config)#host r3
r3(config)#int fa0/0
r3(config-if)#ip add 2.0.0.2 255.0.0.0
r3(config-if)#no shut
r3(config-if)#exit
r3(config)#int fa0/1
r3(config-if)#ip add 192.168.2.1 255.255.255.0
r3(config-if)#no shut

Teraz urobte defaultné smerovanie

ip route 0.0.0.0 0.0.0.0 2.0.0.1

Z routra r1 urobte ping na r3

ping 2.0.0.2

Teraz urobte ping z r3 na R1

ping 1.0.0.1

Teraz na r1 urobte tunnel

r1(config)#interface tunnel 10
ip address 172.16.1.1 255.255.0.0
tunnel source fa0/1
tunnel destination 2.0.0.2

Na routri r3 urobte nasledovnú konfiguráciu

interface tunnel 100
ip address 172.16.1.2 255.255.0.0
tunnel source fa0/0
tunnel destination 1.0.0.1
no sh

Otestujte, či funguje ping medzi dvoma sieťami z r1 na r3

Teraz urobte ping z routra r3

ping 172.16.1.2

ping 172.16.1.1

Teraz vytvorte smerovanie na r1 a R3

ip route 192.168.2.0 255.255.255.0 172.16.1.2

Skontrolujte konfiguráciu na r1

show interface Tunnel 10

Teraz skontrolujte konfiguráciu na r3

show interface Tunnel 100

Na záver prideľte IP adresy počítačom

PC 1 = 192.168.1.2

PC 2 = 192.168.2.2

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

VOIP prepojenie dvoch sietí, router rip a E-mail server

na routri IBASTERISK urobte následovný config

router IBASTERISK

interface serial 1/0
ip add 10.0.1.1. 255.255.255.252
clock rate 56000
no sh
exit
write

interface fa0/0
ip add 192.168.1.1 255.255.255.224
no sh

router rip
version 2
network 192.168.1.0
network 10.0.1.0

ip dhcp pool CATC
network 192.168.1.0 255.255.255.224
defaul-router 192.168.1.1
option 150 ip 192.168.1.1

telephony-service
max-ephoines 4
max-dn 4
source-address 192.168.1.1 port 2000
auto assign 4 to 6
auto assign 1 to 5

ephone-dn 1
number 1101

ephone-dn 2
number 1102

ephone-dn 3
number 1103
exit
ephone-dn 4
number 1104


dial-peer voice 1 voip 
destination-pattern 12..
ession target ipv4:10.0.1.2
exit

hostname IBASTERISK

telephony-service
max-ephones 4
max-dn 4
ip spurce-address
ip source-address 192.168.1.1 port 2000
auto assign 4 to 6
auto assign 1 to 5

Počítače prepnite zo statického IP adresovania na DHCP

Telefóny pripojte na napájanie

Na Switchi IBASTERISKSW urobte konfiguráciu

interface range fa0/1-5
switchport voice vlan 1

Na routri VOIP urobte následovnú konfiguráciu

interface serial 1/0
ip add 10.0.1.2 255.255.255.252
no sh
exit
write

interface fastethernet 0/0
ip ad 172.16.1.1 255.255.255.224
router rip
version 2
network 172.16.1.0
nework 10.0.1.2

ip dhcp pool CATC
network 172.16.1.1 255.255.255.224
default-rouer 172.16.1.1
 option 150 ip 172.16.1.1

telephony-service
max-ephones 4
max-dn 4
source-address 172.16.1.1 port 2000
auto assign 4 to 6
auto assign 1 to 5

ephone-dn 1
number 1201

ephone-dn 2
1203

ephone-dn 3
1201

dial-peer voice 1 voip 
destination-pattern 11..
session target ipv4:10.0.1.1

hostname VOIP

Počítače nastavne na DHCP vrátene serveru, kde nastavíme emailový server

Nastavte kontá na počítačoch

Skontroľujte prenos

Teraz skúste uskutočniť hovor z jednej siete na druhú

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.3.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

DHCP, ROUTER RIP, Email server

Na routri IBASTERISK urobíme následovnu konfiguráciu:

  • router pomenujeme
  • začneme konfigurovať interface fa0/0
  • pridelíme IP adresu 192.168.1.1 255.255.255.0
  • zadáme príkaz na to aby sa interface zapól
  • nastavíme DHCP na routri
  • začneme od rozsahu 192.168.1.0 255.255.255.0
  • nastavíme to na východzom routri (default router) 192.168.1.1
  • nastavíme DNS server 192.168.1.1
  • Nakonfigurujeme teraz sériový port s IP adresou 10.0.0.1 255.0.0.0
  • Clock rate. Clock rate sa nastavuije na routri, kde je na sériovom porte zobrazená samica. To nájdete na schéme s označením hodiniek
  • Teraz nastavíme router RIP. RIP je protokól na smerovanie. Zvolíme siete 192.168.1.0 a 10.0.0.0
hostname IBASTERISK
int fa0/0
ip add 192.168.1.1 255.255.255.0
no shutdown
exit

ip dhcp pool IBASTERISK
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.1 
exit

int se1/0
ip add 10.0.0.1 255.0.0.0.0
clock rate 64000
exit
router rip
network 192.168.1.0
network 10.0.0.0
exit
write

Keď to mámé hotové overte, či DHCP prideľuje počítačom IP adresu

Na routri, ktorý mám pomenovaný, ako JASMIN

urobíme nasledovné príkazpríkazy

hostname JASMIN
int fa0/0
ip add 192.168.2.1 255.255.255.0
no shutdown
exit
ip dhcp pool IBASTERISK
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1 
exit

int se1/0
ip add 10.0.0.2 255.0.0.0.0
exit
router rip
network 192.168.2.0
network 10.0.0.0
exit

int se1/1 
ip add 20.0.0.1 255.0.0.0
exit
router rip
network 10.0.0.0
network 20.0.0.0
network 192.168.2.0
write

Na routri ACTIVE24 urobím,e následovné príkazy

hostname ACTIVE24
interface se1/0
ip add 20.0.0.2 255.0.0.0
no sh
exit

ip dhcp pool ACTIVE24
network 192.168.3.1 255.255.255.0
defaul-router 192.168.3.1
dns-server 192.168.3.1
exit


route rip
network 192.168.3.0
network 20.0.0.0
exit
write

Na ostatných počítačoch nastavte, aby si IP adresu stiahli z DHCP

Teraz zo siete otestujte, či Vám funguje komunikácie siete. Najednoduchejší spôsob, ako zistiť overejne siete, je že urobíte ping. Čiže zo siete 192.168.1.1 urobíme ping na sieť 192.168.2.1 a 192.168.3.1

Keď úspešne prešli, tak urobíme konfiguráciu e-mailového servera

Kliklnite na server

Nasatvte Domain Name v mojom prípade active24.cz ca vytvorte užívateľov a kliknite na plus

Teraz, si ovore počítače, kde chcete nastaviť emailové konto

Zvoľte save

Nastavte ostatné konta

Teraz vyskúšajte, či funguej odosielanie emailov

Z počítača Ivan odošlem email na Michala

Choďte na počítač Michal

Otvotre email

Ak vám email neprišiel kliknite na tlačítko recive (prijať)

Riešenie problémov

  • nevytvárajte užívateľov user1 user2 a podone. Cisco packet tracer má s tým problém

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

Cisco Packet Tracer

https://2.bp.blogspot.com/-91Og1JzFXQk/XYlLgeNB2LI/AAAAAAAAIxc/R95KsDWvm8QxcyznPqZfwpotw57FZ6v7gCLcBGAsYHQ/s320/Packet%2BTracer.png

Cisco packet tracer je program na učenie počítačových sietí. (Simulátor.), kde si môžete vyskúšať konfiguráciu routrov, switchov, vlan, konfiguráciu IP telefónov.

  1. Choďte na web stránku https://www.netacad.com
  2. Prihláste sa alebo sa registrujte
  3. Resources >> Download Packet Tracer

4. Kliknite pravým tlačítkom na Otvoriť pomocou inštalátor balíkov GDebi

5. Zvoľte inštalovať balík

6. Zadajte heslo

Do inštalujte ďalší softvér

a môžete používať

UPOZORNENIE: BEZ PRIHLÁSENIA NEMÔŽETE POUŽÍVAŤ CISCO PACKET TRACER.

Cloud pomocou DSL modemu

Server prepojte cloudom pomocou fastethernet a fastethernet 6

Zadajte IP adresu na server 192.168.0.1, server nechajte na statickej IP adrese.

Pomenujte DSL modemy

Nastavte porty z modemu na cloud. Modem 4 a modem 5. Na prepojenie modemov použite tento kábel:

Na cloude config DSL a pridajte modemy

Pripojte počítače a notebooky

Pomenujte switche Bratislava2 Ibasterisk2. Názov je ľubovoľný

Prepnite všetky počítače do DHCP

Vyskúšajte ping. Počítače sú v dvoch sieťach. Siete sa medzi sebou vidieť nebudú, ale mali vidieť Cloud, inak povedané server. Z ľubovoľného počítača, keď zadáte príkaz ping 192.168.0.1. To je IP adresa Servera pripojený na cloud.

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

ROUTER RIP

ROUTER RIP je v informatike smerovací protokol, na komunikáciu medzi routrami v sieti. V tomto cvičení si ukážeme, ako konfigurovať ROUTER RIP.

Na Routri, ktorý mám označený, ako router 0 napíšte

# eneble

# configure terminal

# interface fastethernet 0/0

# ip add 192.168.1.2 255.255.255.0

# no sh

# do wr

# exit

# interface serial 0/0/0

# ip add 192.168.5.1 255.255.255.0

# no sh

# do wr

# router rip

# version 2

# network 192.168.1.0

#network 192.168.5.0

# do wr

Na routri, ktorý mám označený ako router 1

# enable

# configure terminal

# fast ethernet 0/0

# ip add 192.168.4.1 255.255.255.0

# no sh

# do wr

# exit

# interface se0/0/0

# ip add ip add 192.168.5.2 255.255.255.0

# no sh

# do wr

# exit

# router rip

# version 2

# network 192.168.4.0

# network 192.168.5.0

# do wr

Teraz ešte musíme da5 počítačom IP adresy, keďže nemáme v tomto cvičení urobený DHCP server, tak IP zadáme manuálne.

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

DHCP pomocou DHCP servera

Navrhnite si topológiu

Teraz na servery zvoľte Services a nájdite DHCP

  • Ako prvé musíte DHCP zapnúť
  • Pool Name: IBASTERISK
  • Default Gateway 192.168.1.1
  • DNS Server 192.168.1.2
  • Start IP: 192.168.1.0
  • Subnet Mask: 255.255.255.0

A v poslednom kroku Save

Teraz treba ísť na Desktop na servery a treba tam vypísať údaje podľa vzoru

Kvoli nejakej záhadnej chybe v Cisco packet Tracer treba do do už vopred nastaveneho DHCP poll (serverPool) napísať tie isté hodnoty, aby nám pocítače v sieti zobrali:

  • IP adresu
  • Subnet Mask
  • DEfault Gateway
  • DNS server

A teraz, keď na počítačoch zvolíte DHCP, tak sa všetko krásne pridelí

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

DHCP – Pomocou Routra

DHCP – je prideľovanie IP adries. Môže byť statické, alebo dinamické

Takú jednoduchú konfiguráciu DHCP si ukážeme v tomto článku. Budeme to konfigurovať pomocou Routra a Switcha.

Budeme na to potrebovať:

  • Počítače
  • Switch 2960
  • Router 2811

Na Routri začneme konfigurovať:

Router>enable
Router#conf t
#int fa0/0
#ip add 192.168.1.1 255.255.255.0
#no shutdown
#exit
# ip dhcp pool IBASTERISK
#network 192.168.1.0 255.255.255.0
#default-router 192.168.1.1
#dns-server 192.168.1.1 

Keď to je hotové prepnite počítače na DHCP

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.

VoIP – Cisco

VoIP-Voice over Internet Protocol. Je to technológia, umožňujúca prenos digitálneho hlasu prostredníctvom počítačovej siete. Firmy, ktoré robia VoIP technológie sú:

Tento článok bude venovaný konfigurácií jednoduchej VoIP sieti Cisco.

Na vytvorenie VoIP v Cisco, budeme potrebovať:

  • Router 2811
  • Switch 2960
  • IP telefóny 7960

Príprava siete

  • V prvom kroku nastavíme na počítačoch DHCP automaticky, a nie staticky
  • Na prepojenie počítačov a telefónov použijeme straight-Through kábel. (rovný kábel)

Prepojenie zvolíme FastEthernet0

  • Zopakujeme aj pri ostatných telefónoch
  • Telefón napojíme na Switch
  • Zvolíme tam FastEthernet
  • Je jedno, ako pripojíme FastEthernet, ale aby v tom bol poriadok tak som to urobil takto:

Prvý krok je zapojiť telefón

  • Teraz, keď máme všetko hotové tak, ako prvé zapneme telefóny.
  • Otvorte si telefón a pripojte kábel
  • Zopakujte aj pri ostatných

Výsledok mali by ste mať „zelené guličky“:

Konfigurácia Switch-u

  • Kliknite na Switch a zvoľte CLI

# conft t

  1. Vytvoríme teraz Vlan-y (na Switch)

# vlan 10

# name DATA

# vlan 20

# name VOICE

# vlan 30

# Name MGT

# vlan 40             

# name MISC

# vlan 50

# name NATIVE

# exit

Teraz ideme nakonfigurovať Fastethernet na Router. V mojej schéme to je fa0/1

  1. Na Switch napíšeme

# switchport mode trunk

# switchport native vlan 50

# exit

  • Teraz a pripojíme na 0/2-4

# int range fa0/2-4

# switchport mode access

# switchport access vlan 10

# switchport voice vlan 20

# exit

# int range fa0/5-24

# switchport mode access

# switchport access vlan 40

# shut

# int range gig0/1-2

# switchport mode access

# switchport access vlan 40

# shut

# end

# show vlan brief

Ak je všetko správne nakonfigurované tak by ste mali dostať takýto výstup:

# copy running-config startup-config

Konfigurácia Routra

  • Opäť kliknite na CLI, ako pri Switchi

Objaví sa Vám  takáto hláška napíšte no

Dôvodom je, že nechceme sprievodcu, ale chceme si to nakonfigurovať sami.

# enable

# conf t

# int fa0/0.10

# encapsulation dot1Q 10

# ip address 192.168.10.1 255.255.255.0

# exit

#  interface fastEthernet 0/0.20
# encapsulation dot1Q 20

# ip address 192.168.20.1 255.255.255.0

# exit

# int fastEthernet 0/0.50

# encapsulation dot1Q 50 native

# exit

# int fastEthernet 0/0

# no shutdown

Výstup:

# exit

# ip dhcp excluded-address 192.168.10.1 192.168.10.5

# ip dhcp excluded-address 192.168.20.1 192.168.20.5

# dhcp pool DATA10

# network 192.168.10.0 255.255.255.0

# default-router 192.168.10.1

# ip dhcp pool VOICE20

# network 192.168.20.0 255.255.255.0

# default-router 192.168.20.1

# option 150 ip 192.168.20.1

# exit

# telephony-service

# max-dn 3

# max-ephones 3

# ip source-address 192.168.20.1 port 2000

# ephone-dn 1

# ephone-dn 2

# number 1020

# ephone-dn 3

# number 1030

# ephone 1

#  type 7960

# button 1:1

Tu Vás môže Cisco Packet Packet vyzvať s chybou Need to configure ephone mac address or VM station-id. Nič sa nedeje napíšte iba príkaz na pridelenie MAC adresy:

#mac-address 006.2A8D.8BA8

Tento krok urobte aj pri ostatných telefónoch:

# ephone 2

# type 7960

# Button 1:2

# ephone 3

# type 7960

# button 1:3

# mac-address 00E0.B0C4.917E

# ephone 3

# type 7960

# ephone 3

# button 1:3

#mac-address 0060.5C99.7C15

# end

# copy running-config startup-config

Keď sa telefóny aj tak nechcú registrovať. Odpojiť kábel a na novo zapojiť.

MAC adresu telefónov nájdete tak, že s kurzorom myšky pôjdete na  telefón, ale nebudete klikať len počkáte kým sa neobjaví  pri telefóne tabuľka. To čo nájdete v rámčeku, to sú MAC adresy telefónov.

Uskutočnený hovor v Cisco Packet Tracer vyzerá následovne:

Hotový projekt vytvorený v Cisco Packet Tracer si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Windows si viete stiahnuť tu

Cisco Packet Tracer 7.2.1 na Linux Desktop si viete stiahnuť tu

Keď si program stiahnete, tak jediné, čo musíte urobiť je si spraviť registráciu na tu

Po registrácií môžete program používať. Program je bezplatný. Tento môj projekt bol robený v staršej verzií, ale ide otvoriť aj v tomto novšom programe.