Zábavné skripty na Mikrotik

Ak Váš Mikrokik ma reproduktor (osvedčené modely): RB2011 Series a 951Ui môžete spustiť zvukové skripty

Ako prvé si ukážeme, ako sa vytvára skript

  1. Pripojte sa na Mikrotik pomocou Winbox
  2. Otvorte system

Nájdite scripts

Kliknite na plus +

Kliknite na Apply

Keď je hotový kliknite na Run Script

Príklady na humorné skripty:

Super Mario

:beep frequency=660 length=100ms;
:delay 150ms;
:beep frequency=660 length=100ms;
:delay 300ms;
:beep frequency=660 length=100ms;
:delay 300ms;
:beep frequency=510 length=100ms;
:delay 100ms;
:beep frequency=660 length=100ms;
:delay 300ms;
:beep frequency=770 length=100ms;
:delay 550ms;
:beep frequency=380 length=100ms;
:delay 575ms;

:beep frequency=510 length=100ms;
:delay 450ms;
:beep frequency=380 length=100ms;
:delay 400ms;
:beep frequency=320 length=100ms;
:delay 500ms;
:beep frequency=440 length=100ms;
:delay 300ms;
:beep frequency=480 length=80ms;
:delay 330ms;
:beep frequency=450 length=100ms;
:delay 150ms;
:beep frequency=430 length=100ms;
:delay 300ms;
:beep frequency=380 length=100ms;
:delay 200ms;
:beep frequency=660 length=80ms;
:delay 200ms;
:beep frequency=760 length=50ms;
:delay 150ms;
:beep frequency=860 length=100ms;
:delay 300ms;
:beep frequency=700 length=80ms;
:delay 150ms;
:beep frequency=760 length=50ms;
:delay 350ms;
:beep frequency=660 length=80ms;
:delay 300ms;
:beep frequency=520 length=80ms;
:delay 150ms;
:beep frequency=580 length=80ms;
:delay 150ms;
:beep frequency=480 length=80ms;
:delay 500ms;

:beep frequency=510 length=100ms;
:delay 450ms;
:beep frequency=380 length=100ms;
:delay 400ms;
:beep frequency=320 length=100ms;
:delay 500ms;
:beep frequency=440 length=100ms;
:delay 300ms;
:beep frequency=480 length=80ms;
:delay 330ms;
:beep frequency=450 length=100ms;
:delay 150ms;
:beep frequency=430 length=100ms;
:delay 300ms;
:beep frequency=380 length=100ms;
:delay 200ms;
:beep frequency=660 length=80ms;
:delay 200ms;
:beep frequency=760 length=50ms;
:delay 150ms;
:beep frequency=860 length=100ms;
:delay 300ms;
:beep frequency=700 length=80ms;
:delay 150ms;
:beep frequency=760 length=50ms;
:delay 350ms;
:beep frequency=660 length=80ms;
:delay 300ms;
:beep frequency=520 length=80ms;
:delay 150ms;
:beep frequency=580 length=80ms;
:delay 150ms;
:beep frequency=480 length=80ms;
:delay 500ms;

:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=760 length=100ms;
:delay 100ms;
:beep frequency=720 length=100ms;
:delay 150ms;
:beep frequency=680 length=100ms;
:delay 150ms;
:beep frequency=620 length=150ms;
:delay 300ms;

:beep frequency=650 length=150ms;
:delay 300ms;
:beep frequency=380 length=100ms;
:delay 150ms;
:beep frequency=430 length=100ms;
:delay 150ms;

:beep frequency=500 length=100ms;
:delay 300ms;
:beep frequency=430 length=100ms;
:delay 150ms;
:beep frequency=500 length=100ms;
:delay 100ms;
:beep frequency=570 length=100ms;
:delay 220ms;

:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=760 length=100ms;
:delay 100ms;
:beep frequency=720 length=100ms;
:delay 150ms;
:beep frequency=680 length=100ms;
:delay 150ms;
:beep frequency=620 length=150ms;
:delay 300ms;

:beep frequency=650 length=200ms;
:delay 300ms;

:beep frequency=1020 length=80ms;
:delay 300ms;
:beep frequency=1020 length=80ms;
:delay 150ms;
:beep frequency=1020 length=80ms;
:delay 300ms;

:beep frequency=380 length=100ms;
:delay 300ms;
:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=760 length=100ms;
:delay 100ms;
:beep frequency=720 length=100ms;
:delay 150ms;
:beep frequency=680 length=100ms;
:delay 150ms;
:beep frequency=620 length=150ms;
:delay 300ms;

:beep frequency=650 length=150ms;
:delay 300ms;
:beep frequency=380 length=100ms;
:delay 150ms;
:beep frequency=430 length=100ms;
:delay 150ms;

:beep frequency=500 length=100ms;
:delay 300ms;
:beep frequency=430 length=100ms;
:delay 150ms;
:beep frequency=500 length=100ms;
:delay 100ms;
:beep frequency=570 length=100ms;
:delay 420ms;

:beep frequency=585 length=100ms;
:delay 450ms;

:beep frequency=550 length=100ms;
:delay 420ms;

:beep frequency=500 length=100ms;
:delay 360ms;

:beep frequency=380 length=100ms;
:delay 300ms;
:beep frequency=500 length=100ms;
:delay 300ms;
:beep frequency=500 length=100ms;
:delay 150ms;
:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=760 length=100ms;
:delay 100ms;
:beep frequency=720 length=100ms;
:delay 150ms;
:beep frequency=680 length=100ms;
:delay 150ms;
:beep frequency=620 length=150ms;
:delay 300ms;

:beep frequency=650 length=150ms;
:delay 300ms;
:beep frequency=380 length=100ms;
:delay 150ms;
:beep frequency=430 length=100ms;
:delay 150ms;

:beep frequency=500 length=100ms;
:delay 300ms;
:beep frequency=430 length=100ms;
:delay 150ms;
:beep frequency=500 length=100ms;
:delay 100ms;
:beep frequency=570 length=100ms;
:delay 220ms;

:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=760 length=100ms;
:delay 100ms;
:beep frequency=720 length=100ms;
:delay 150ms;
:beep frequency=680 length=100ms;
:delay 150ms;
:beep frequency=620 length=150ms;
:delay 300ms;

:beep frequency=650 length=200ms;
:delay 300ms;

:beep frequency=1020 length=80ms;
:delay 300ms;
:beep frequency=1020 length=80ms;
:delay 150ms;
:beep frequency=1020 length=80ms;
:delay 300ms;

:beep frequency=380 length=100ms;
:delay 300ms;
:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=760 length=100ms;
:delay 100ms;
:beep frequency=720 length=100ms;
:delay 150ms;
:beep frequency=680 length=100ms;
:delay 150ms;
:beep frequency=620 length=150ms;
:delay 300ms;

:beep frequency=650 length=150ms;
:delay 300ms;
:beep frequency=380 length=100ms;
:delay 150ms;
:beep frequency=430 length=100ms;
:delay 150ms;

:beep frequency=500 length=100ms;
:delay 300ms;
:beep frequency=430 length=100ms;
:delay 150ms;
:beep frequency=500 length=100ms;
:delay 100ms;
:beep frequency=570 length=100ms;
:delay 420ms;

:beep frequency=585 length=100ms;
:delay 450ms;

:beep frequency=550 length=100ms;
:delay 420ms;

:beep frequency=500 length=100ms;
:delay 360ms;

:beep frequency=380 length=100ms;
:delay 300ms;
:beep frequency=500 length=100ms;
:delay 300ms;
:beep frequency=500 length=100ms;
:delay 150ms;
:beep frequency=500 length=100ms;
:delay 300ms;

:beep frequency=500 length=60ms;
:delay 150ms;
:beep frequency=500 length=80ms;
:delay 300ms;
:beep frequency=500 length=60ms;
:delay 350ms;
:beep frequency=500 length=80ms;
:delay 150ms;
:beep frequency=580 length=80ms;
:delay 350ms;
:beep frequency=660 length=80ms;
:delay 150ms;
:beep frequency=500 length=80ms;
:delay 300ms;
:beep frequency=430 length=80ms;
:delay 150ms;
:beep frequency=380 length=80ms;
:delay 600ms;

:beep frequency=500 length=60ms;
:delay 150ms;
:beep frequency=500 length=80ms;
:delay 300ms;
:beep frequency=500 length=60ms;
:delay 350ms;
:beep frequency=500 length=80ms;
:delay 150ms;
:beep frequency=580 length=80ms;
:delay 150ms;
:beep frequency=660 length=80ms;
:delay 550ms;

:beep frequency=870 length=80ms;
:delay 325ms;
:beep frequency=760 length=80ms;
:delay 600ms;

:beep frequency=500 length=60ms;
:delay 150ms;
:beep frequency=500 length=80ms;
:delay 300ms;
:beep frequency=500 length=60ms;
:delay 350ms;
:beep frequency=500 length=80ms;
:delay 150ms;
:beep frequency=580 length=80ms;
:delay 350ms;
:beep frequency=660 length=80ms;
:delay 150ms;
:beep frequency=500 length=80ms;
:delay 300ms;
:beep frequency=430 length=80ms;
:delay 150ms;
:beep frequency=380 length=80ms;
:delay 600ms;

:beep frequency=660 length=100ms;
:delay 150ms;
:beep frequency=660 length=100ms;
:delay 300ms;
:beep frequency=660 length=100ms;
:delay 300ms;
:beep frequency=510 length=100ms;
:delay 100ms;
:beep frequency=660 length=100ms;
:delay 300ms;
:beep frequency=770 length=100ms;
:delay 550ms;
:beep frequency=380 length=100ms;
:delay 575ms;

Jingle Bells

:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 600ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 600ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=783 length=150ms
:delay 300ms;
:beep frequency=523 length=150ms
:delay 300ms;
:beep frequency=587 length=150ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 750ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=698 length=300ms
:delay 450ms;
:beep frequency=698 length=225ms
:delay 150ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=659 length=225ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 525ms;
:beep frequency=659 length=225ms
:delay 125ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=587 length=150ms
:delay 300ms;
:beep frequency=587 length=150ms
:delay 300ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=587 length=750ms
:delay 675ms;
:beep frequency=783 length=525ms
:delay 750ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 600ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 600ms;
:beep frequency=659 length=150ms
:delay 300ms;
:beep frequency=783 length=150ms
:delay 300ms;
:beep frequency=523 length=150ms
:delay 300ms;
:beep frequency=587 length=150ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 750ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=698 length=300ms
:delay 450ms;
:beep frequency=698 length=225ms
:delay 150ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=659 length=225ms
:delay 300ms;
:beep frequency=659 length=300ms
:delay 525ms;
:beep frequency=659 length=150ms
:delay 125ms;
:beep frequency=783 length=150ms
:delay 300ms;
:beep frequency=783 length=150ms
:delay 300ms;
:beep frequency=698 length=150ms
:delay 300ms;
:beep frequency=587 length=150ms
:delay 300ms;
:beep frequency=523 length=375ms
:delay 300ms;

Aha – take on me

:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=587 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=494 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=659 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=659 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=831 length=188ms; 
:delay 198ms; 
:beep frequency=831 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=988 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=587 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=740 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=740 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=587 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=494 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=659 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=659 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=831 length=188ms; 
:delay 198ms; 
:beep frequency=831 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=988 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=880 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=587 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=740 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=740 length=188ms; 
:delay 198ms; 
:delay 188ms; 

:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms; 
:beep frequency=740 length=188ms; 
:delay 198ms; 
:beep frequency=659 length=188ms; 
:delay 198ms;

Chang

:for j from=1 to=4 step=1 do={
:for i from=2000 to=50 step=-400 do={
:beep frequency=$i length=11ms;
:delay 11ms;
}
:for i from=800 to=2000 step=400 do={
:beep frequency=$i length=11ms;
:delay 11ms;
}
}

Coo

:for i from=0 to=150 step=10 do={
 :beep frequency=(1295 - i) length=22ms;
 :delay 22ms;
 :beep frequency=(1095 + i) length=22ms;
 :delay 22ms;
 }

Fanfare

 :for t from=1200 to=350 step=-50 do={
 :beep frequency=$t length=33ms;
 :delay 33ms;
 }

Larm

 :for t1 from=1 to=10 step=1 do={
 :for t2 from=300 to=1800 step=40 do={
 :beep frequency=$t2 length=11ms;
 :delay 11ms;
 }
 }

Maschinengewehr

 :for t from=1 to=20 step=1 do={
 :beep frequency=40 length=33ms;
 :delay 33ms;
 :delay 55ms;
 }

Oh

:for i from=800 to=2000 step=100 do={
 :beep frequency=$i length=11ms;
 :delay 11ms;
 }
 :for i from=2000 to=50 step=-100 do={
 :beep frequency=$i length=11ms;
 :delay 11ms;
 }

Phone

 :for i from=1 to=10 step=1 do={
 :beep frequency=1195 length=22ms;
 :delay 22ms;
 :beep frequency=2571 length=22ms;
 :delay 22ms;
 }

Portal

:put "This "
:beep frequency=784 length=200ms;
:delay 200ms;
:put "was "
:beep frequency=740 length=200ms;
:delay 200ms;
:put "a "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "triumph."
:beep frequency=659 length=200ms;
:delay 200ms;
:beep frequency=740 length=200ms;
:delay 1000ms;
:put "I'm making "
:beep frequency=784 length=200ms;
:delay 200ms;
:beep frequency=740 length=200ms;
:delay 200ms;
:put "a "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "note "
:beep frequency=659 length=200ms;
:delay 500ms;
:put "here: "
:beep frequency=740 length=200ms;
:delay 200ms;
:put "huge "
:beep frequency=587 length=200ms;
:delay 500ms;
:put "success."
:beep frequency=659 length=200ms;
:delay 200ms;
:beep frequency=440 length=200ms;
:delay 1000ms;
:put "It's "
:beep frequency=440 length=200ms;
:delay 200ms;
:put "hard "
:beep frequency=659 length=300ms;
:delay 300ms;
:put "to "
:beep frequency=740 length=200ms;
:delay 200ms;
:put "overstate "
:beep frequency=784 length=300ms;
:delay 300ms;
:beep frequency=659 length=300ms;
:delay 300ms;
:beep frequency=554 length=200ms;
:delay 300ms;
:put "my "
:beep frequency=587 length=200ms;
:delay 200ms;
:put "satisfaction."
:beep frequency=659 length=300ms;
:delay 400ms;
:beep frequency=440 length=300ms;
:delay 300ms;
:beep frequency=440 length=200ms;
:delay 200ms;
:beep frequency=740 length=200ms;
:delay 1200ms;
:put "Aperture "
:beep frequency=784 length=200ms;
:delay 200ms;
:beep frequency=740 length=200ms;
:delay 200ms;
:beep frequency=659 length=200ms;
:delay 200ms;
:put "science."
:beep frequency=659 length=200ms;
:delay 200ms;
:beep frequency=740 length=200ms;
:delay 1000ms;
:put "We "
:beep frequency=784 length=200ms;
:delay 200ms;
:put "do what "
:beep frequency=740 length=200ms;
:delay 200ms;
:put "we "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "must "
:beep frequency=659 length=200ms;
:delay 500ms;
:put "because "
:beep frequency=740 length=200ms;
:delay 200ms;
:beep frequency=587 length=200ms;
:delay 500ms;
:put "we "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "can."
:beep frequency=440 length=200ms;
:delay 1000ms;
:put "For "
:beep frequency=659 length=300ms;
:delay 300ms;
:put "the "
:beep frequency=740 length=200ms;
:delay 200ms;
:put "good "
:beep frequency=784 length=300ms;
:delay 300ms;
:put "of "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "all "
:beep frequency=554 length=300ms;
:delay 300ms;
:put "of "
:beep frequency=587 length=200ms;
:delay 200ms;
:put "us."
:beep frequency=659 length=400ms;
:delay 500ms;
:put "Except "
:beep frequency=440 length=200ms;
:delay 200ms;
:beep frequency=587 length=200ms;
:delay 200ms;
:put "the "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "ones "
:beep frequency=698 length=200ms;
:delay 200ms;
:put "who "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "are "
:beep frequency=587 length=200ms;
:delay 200ms;
:put "dead."
:beep frequency=523 length=200ms;
:delay 600ms;
:beep frequency=440 length=200ms;
:delay 200ms;
:put "But "
:beep frequency=466 length=300ms;
:delay 300ms;
:put "there's "
:beep frequency=523 length=300ms;
:delay 300ms;
:put "no "
:beep frequency=698 length=200ms;
:delay 300ms;
:put "sense "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "crying "
:beep frequency=587 length=200ms;
:delay 200ms;
:beep frequency=587 length=200ms;
:delay 200ms;
:put "over "
:beep frequency=523 length=200ms;
:delay 250ms;
:beep frequency=587 length=200ms;
:delay 200ms;
:put "every "
:beep frequency=523 length=200ms;
:delay 250ms;
:put "mistake,"
:beep frequency=523 length=300ms;
:delay 350ms;
:beep frequency=523 length=200ms;
:delay 400ms;
:beep frequency=440 length=200ms;
:delay 200ms;
:put "You "
:beep frequency=466 length=300ms;
:delay 300ms;
:put "just "
:beep frequency=523 length=300ms;
:delay 300ms;
:put "keep "
:beep frequency=698 length=200ms;
:delay 300ms;
:put "on "
:beep frequency=783 length=200ms;
:delay 200ms;
:put "trying "
:beep frequency=698 length=200ms;
:delay 200ms;
:beep frequency=659 length=250ms;
:delay 250ms;
:put "til "
:beep frequency=587 length=200ms;
:delay 200ms;
:put "you "
:beep frequency=587 length=200ms;
:delay 200ms;
:put "run "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "out"
:beep frequency=698 length=300ms;
:delay 350ms;
:put "of "
:beep frequency=698 length=300ms;
:delay 400ms;
:put "cake "
:put "And "
:beep frequency=783 length=200ms;
:delay 200ms;
:put "the "
:beep frequency=880 length=200ms;
:delay 200ms;
:put "science "
:beep frequency=932 length=200ms;
:delay 200ms;
:beep frequency=932 length=200ms;
:delay 200ms;
:put "gets "
:beep frequency=880 length=200ms;
:delay 250ms;
:put "done"
:beep frequency=783 length=300ms;
:delay 300ms;
:put "and "
:beep frequency=698 length=200ms;
:delay 200ms;
:put "you "
:beep frequency=783 length=200ms;
:delay 200ms;
:put "make "
:beep frequency=880 length=200ms;
:delay 200ms;
:put "a "
:beep frequency=880 length=200ms;
:delay 200ms;
:put "neat "
:beep frequency=783 length=200ms;
:delay 250ms;
:put "gun"
:beep frequency=698 length=300ms;
:delay 400ms;
:put "for "
:beep frequency=587 length=200ms;
:delay 200ms;
:put "the "
:beep frequency=523 length=200ms;
:delay 200ms;
:put "people "
:beep frequency=587 length=200ms;
:delay 200ms;
:beep frequency=698 length=200ms;
:delay 200ms;
:put "who "
:beep frequency=698 length=200ms;
:delay 200ms;
:put "are "
:beep frequency=659 length=300ms;
:delay 350ms;
:put "STILL "
:beep frequency=659 length=200ms;
:delay 200ms;
:put "ALIVE "
:beep frequency=739 length=100ms;
:delay 100ms;
:beep frequency=739 length=400ms;
:delay 400ms;

Sad

:beep frequency=784 length=500ms;
 :delay 500ms;

:beep frequency=738 length=500ms;
 :delay 500ms;

:beep frequency=684 length=500ms;
 :delay 500ms;

:beep frequency=644 length=1000ms;
 :delay 1000ms;

Samba

:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=600ms; 
:delay 610ms; 
:beep frequency=659 length=225ms; 
:delay 235ms; 
:beep frequency=880 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=225ms; 
:delay 235ms; 
:beep frequency=880 length=225ms; 
:delay 235ms; 
:beep frequency=988 length=600ms; 
:delay 610ms; 
:beep frequency=784 length=300ms; 
:delay 310ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=450ms; 
:delay 460ms; 
:beep frequency=988 length=300ms; 
:delay 310ms; 
:beep frequency=1319 length=600ms; 
:delay 610ms; 
:beep frequency=1175 length=225ms; 
:delay 235ms; 
:beep frequency=1319 length=225ms; 
:delay 235ms; 
:beep frequency=1480 length=600ms; 
:delay 610ms; 
:beep frequency=1175 length=300ms; 
:delay 310ms; 
:beep frequency=988 length=450ms; 
:delay 460ms; 
:beep frequency=988 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=988 length=300ms; 
:delay 310ms; 
:beep frequency=880 length=600ms; 
:delay 610ms; 
:beep frequency=784 length=225ms; 
:delay 235ms; 
:beep frequency=880 length=225ms; 
:delay 235ms; 
:beep frequency=988 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=450ms; 
:delay 460ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=1568 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=1175 length=225ms; 
:delay 235ms; 
:beep frequency=1319 length=225ms; 
:delay 235ms; 
:beep frequency=1480 length=450ms; 
:delay 460ms; 
:beep frequency=1175 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=1800ms; 
:delay 1810ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=600ms; 
:delay 610ms; 
:beep frequency=659 length=225ms; 
:delay 235ms; 
:beep frequency=880 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=225ms; 
:delay 235ms; 
:beep frequency=880 length=225ms; 
:delay 235ms; 
:beep frequency=988 length=600ms; 
:delay 610ms; 
:beep frequency=784 length=300ms; 
:delay 310ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=450ms; 
:delay 460ms; 
:beep frequency=988 length=300ms; 
:delay 310ms; 
:beep frequency=1319 length=600ms; 
:delay 610ms; 
:beep frequency=1175 length=225ms; 
:delay 235ms; 
:beep frequency=1319 length=225ms; 
:delay 235ms; 
:beep frequency=1480 length=600ms; 
:delay 610ms; 
:beep frequency=1175 length=300ms; 
:delay 310ms; 
:beep frequency=988 length=450ms; 
:delay 460ms; 
:beep frequency=988 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=988 length=300ms; 
:delay 310ms; 
:beep frequency=880 length=600ms; 
:delay 610ms; 
:beep frequency=784 length=225ms; 
:delay 235ms; 
:beep frequency=880 length=225ms; 
:delay 235ms; 
:beep frequency=988 length=450ms; 
:delay 460ms; 
:beep frequency=784 length=450ms; 
:delay 460ms; 
:beep frequency=659 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=1568 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=450ms; 
:delay 460ms; 
:beep frequency=1175 length=225ms; 
:delay 235ms; 
:beep frequency=1319 length=225ms; 
:delay 235ms; 
:beep frequency=1480 length=450ms; 
:delay 460ms; 
:beep frequency=1175 length=450ms; 
:delay 460ms; 
:beep frequency=1319 length=1200ms; 
:delay 1210ms;

Siren

:for i from=1 to=3 step=1 do={
 :beep frequency=550 length=494ms;
 :delay 494ms;
 :beep frequency=400 length=494ms;
 :delay 494ms;
 }

Sound 1

:beep frequency=600 length=165ms;
 :delay 165ms;

:beep frequency=50 length=83ms;
 :delay 83ms;

:beep frequency=600 length=165ms;
 :delay 165ms;

:beep frequency=50 length=83ms;
 :delay 83ms;

:beep frequency=650 length=165ms;
 :delay 165ms;

:beep frequency=600 length=165ms;
 :delay 165ms;

:beep frequency=50 length=83ms;
 :delay 83ms;

:beep frequency=600 length=165ms;
 :delay 165ms;

:beep frequency=700 length=275ms;
 :delay 275ms;

:beep frequency=800 length=275ms;
 :delay 275ms;

:beep frequency=900 length=110ms;
 :delay 110ms;

Space 1

 :for i from=1000 to=40 step=-20 do={
 :beep frequency=$i length=11ms;
 :delay 11ms;
 }

Space 2

:for i from=10000 to=500 step=-500 do={
 :beep frequency=$i length=11ms;
 :delay 11ms;
 }

Star Wars

:beep frequency=500 length=500ms;
:delay 500ms;
:beep frequency=500 length=500ms;
:delay 500ms;
:beep frequency=500 length=500ms;
:delay 500ms;
:beep frequency=400 length=500ms;
:delay 400ms;
:beep frequency=600 length=200ms;
:delay 100ms;
:beep frequency=500 length=500ms;
:delay 500ms;
:beep frequency=400 length=500ms;
:delay 400ms;
:beep frequency=600 length=200ms;
:delay 100ms;
:beep frequency=500 length=500ms;
:delay 1000ms;
:beep frequency=750 length=500ms;
:delay 500ms;
:beep frequency=750 length=500ms;
:delay 500ms;
:beep frequency=750 length=500ms;
:delay 500ms;
:beep frequency=810 length=500ms;
:delay 400ms;
:beep frequency=600 length=200ms;
:delay 100ms;
:beep frequency=470 length=500ms;
:delay 500ms;
:beep frequency=400 length=500ms;
:delay 400ms;
:beep frequency=600 length=200ms;
:delay 100ms;
:beep frequency=500 length=500ms;
:delay 1000ms;

Tonarkade 2

 :for t from=1250 to=600 step=-8 do={
 :beep frequency=$t length=11ms;
 :delay 11ms;
 }

Victory

:beep frequency=523 length=200ms;
 :delay 1000ms;

:beep frequency=523 length=200ms;
 :delay 1000ms;

:beep frequency=523 length=200ms;
 :delay 1000ms;

:beep frequency=659 length=700ms;
 :delay 700ms;

:beep frequency=784 length=500ms;
 :delay 500ms;

:beep frequency=523 length=200ms;
 :delay 1000ms;

:beep frequency=523 length=200ms;
 :delay 1000ms;

:beep frequency=523 length=200ms;
 :delay 1000ms;

:beep frequency=659 length=700ms;
 :delay 700ms;

:beep frequency=784 length=500ms;
 :delay 800ms;

:beep frequency=784 length=400ms;
 :delay 400ms;

:beep frequency=884 length=200ms;
 :delay 200ms;

:beep frequency=784 length=200ms;
 :delay 200ms;

:beep frequency=687 length=200ms;
 :delay 200ms;

:beep frequency=659 length=200ms;
 :delay 200ms;

:beep frequency=579 length=200ms;
 :delay 200ms;

:beep frequency=519 length=400ms;
 :delay 400ms;

phone call

 :for i from=1 to=10 do={
 /system script run "SQUAWK Phone 1";
 :delay 400ms;
 /system script run "SQUAWK Phone 1";
 :delay 2000ms;
 }

Telephone

 :for t1 from=1 to=4 step=1 do={
 :for t2 from=1 to=25 step=1 do={
 :beep frequency=540 length=33ms;
 :delay 33ms;
 :beep frequency=650 length=27ms;
 :delay 27ms;
 }
 :delay 2000ms;
 }

Továrenské nastavenie Fortigate

Budete potrebovať RS232C a redukciu na USB

  1. Zapojte to do portu Console a do počítača
  2. Kliknite na tento počítač (This Computer) pravým tlačítkom a zvoľte Spravovať (Manage)

Kliknite na Device manager

Zistite v akom COM je zapojený

Teraz spustite program Putty v možnostiach vyberte Serial a napíšte tam port, v mojom prípade to je COM5

Zvoľte Open.

Teraz sa prihláste Administrátorským účtom

Keď ste sa prihlásili napíšte príkaz

execute factoryreset

Stlačte Y

Počkajte kým sa všetko načíta

A keď je náhodou zle meno a heslo?

Zadajte iba sériové číslo zariadenia a stlačte Enter

NAS a Synology multimediálne centrum prepojenie s MikroTik

Nastavenie NAS synology

  1. Je potrebné si ako prvé nainštalovať na NAS Synology WebDAV Server

2. Teraz povoľte porty, na ktorých ma počúvať NAS Synology

3. Kliknite na Apply

Samozrejme, ešte bude treba vytvoriť užívateľov. Ako sa vytvára užívateľ, to nájdete tu:

https://ibasterisk.sk/pridavanie-uzivatelov-a-ich-prava/

Teraz ideme nastaviť PortForwarding na MikroTiku

Kliknite na IP a potom na Firewall

Ako prvé začnime s General

Je potrebné zvoliť:

  • Chain: dstnat (destination nat)
  • Protocol: (v mojom prípade tcp), záleží na Vás, aký protokól potrebujete
  • Dst. Port (Destinanion port), to je na Vás ja som si otvoril port 10443, môžete iné. (Osobne odporúčam si pred otváraním portu pozrieť, či Vám na ňom už nejaká služba nebeží)
  • In. Interface: ether1

Teraz otvotre možnosť Action

Ako prvé zvoľte dst-nat

Zvoľte IP adresu NAS synology, a na port, na ktorom chcete, aby počúvala komunikácia

Kliknite na Apply

Otestujte komunikáciu, keď vytvárate užívateľovi prístup napríklad na IPTV, tak zadávate

  • Protokol:v našom prípade Webdav
  • Port
  • Meno užívateľa
  • Heslo
  • Verejnú IP adresu, na lokalite, kde sa nachádza pripojená NAS

Overte komunikáciu:

Ak si budete chcieť prečítať hlbšie ohľadne Kodi na Raspberry som v minulosti pre netvel.sk písal publikáciu

https://netvel.sk/kodi-multimedialny-server/

WireGuard na Mikrotik

Úvod

WireGuard je jedeno z mnoho riešení na vytvorenie tunela medzi dvoma sieťami. Na trhu je ich hneď niekoľko. Zopár najrozšírenejších spomeniem.

  • OpenVPN
  • VPN and Endpoint Security Clients (Cisco)
  • ForticlientVPN
  • WireGuard
  • A iné

WireGuard sa už pomaly tlačí aj do routrou od spoločnosti Mikrotik, ale zatiaľ je to len v beta verzií. Osobne som sa s tým skúšal hrať, ale bez úspechu. Tak som zvolil druhú možnosť. Naštaštie WireGuard sa dá naištaľovať aj na Raspberry Pi a mám ich požehnane. Ako si naištaľovať WireGuard na Raspberry Pi nájdete v tomto linku:

https://ibasterisk.sk/wireguard-na-raspberry/

Ale samostatná inštalácia a vytvorenie klienta pri Mikrotiku nestačí. Musíte urobiť pár vecí k tomu, aby Vám to fungovalo.

Konfigurácia

Už vieme, že defaultne nastavený WireGuard počúva na porte 51820

Začneme s General

Nastavíme:

  • Dtsnat (destination port)
  • Protocol
  • Dst. Port (destination port)
  • In. Interface (vstupný interface)

Kliknite na Action a nastavte následovné veci:

Overte funkčnosť pomocou klienta:

Fail2Ban na NAS

  1. Ako prvé musíme povolôiť na NAS SSH Secure Shell (port 22)
  2. Ovládací panel
  3. Terminál a SNMP

4. Zvoľte použiť

Inštalácia Python3

  1. Musíte naištalovať Python3, ten naištalujete cez centrum balíčkov

Teraz sa prihláste cez ssh na NAS užívateľom, akého ste si vytvorili na NAS.Manual ako vytvoriť užívateľa nájdete tu

Keď sa pripojíte a napíšete príkaz, tak zistíte verziu naištalovaného Pythone

python

Stiahneme repozitáre z fail2ban

wget --no-check-certificate https://github.com/fail2ban/fail2ban/archive/0.9.5.tar.gz -O /tmp/fail2ban_0.9.5.tar.gz
cd /tmp
tar -zxvf fail2ban_0.9.5.tar.gz
cd /tmp/fail2ban-0.9.5

Pokračujte v inštalácií a skontrolujte, či ste v správnom adresáry

cd /tmp/fail2ban-0.9.5

python setup.py install

Skontrolujte či Fail2ban funguje

fail2ban-client -h

Teraz Fail2ban je nastavený na to aby blokoval prihlásenia z SSH pomocou hesla.

fail2ban-client status
fail2ban-client start
fail2ban-client status
fail2ban-client stop

Teraz vytvoríme skrypt na spustenie Fail2ban

sudo nano /etc/fail2ban/f2b_start.sh
#!/bin/bash

sudo mkdir /var/run/fail2ban
sudo fail2ban-client start

Uložte a pridajte práva

chmod 770 /etc/fail2ban/f2b_start.sh

Tento skrypt môžete otestovať. Ako prvé zastavte Fail2ban a potom spuste pomocou skryptu

fail2ban-client stop
rm -R /var/run/fail2ban
sh /etc/fail2ban/f2b_start.sh
fail2ban-client status
fail2ban-client stop

Teraz choďte na NAS

  1. Otvorte s iovládací panel
  2. Súborové zložky
  3. Plánovač úloh (Task Scheduler)

Teraz môžete pozrieť, či Vám služba beží

fail2ban-client status

Originálny návod nájdete tu:

http://www.iholken.com/index.php/2016/07/22/guide-for-installing-fail2ban-for-synology-nas-devices-and-configuring-it-for-web-services-like-owncloud-or-wordpress/

Konfigurácia SMB

Čo je SMB

Samba (Server Message Block) Slúži na vzdialený prístup k súborom. SMB počúva štandartne na porte 445

Ako prvé musíte nastaviť na Routri Port forwarding. Každý router to má individuálne. Tak vám to ukážem na routri Asus RT-AC55U

  1. Choďte do WAN

2. Povoľte Port Forwarding

Príklad vytvorenia Port Forwarding

3. Zvoľte uložiť

Ak máte všetko hotové, tak choďte na NAS do ovládací panel

súborové služby

Povoľte SMB

Zvoľte možnosť použiť

Pridávanie užívateľov a ich práva

  1. Kliknite na ovládací panel

2. Kliknite na užívateľ

3. Zvoľte možnosť vytvoriť

4. Vytvorte užívateľa podľa obrázku

  • Email a popis nieje podstatný
  • Podstatné je iba meno a heslo

5. Kliknite ďalej

6. V ďalšom kroku sa rozhodujete či bude užívateľ v skupine administrátori alebo užívatelia

7. V ďalšom kroku vyberáte prístup do akých priečinkov bude mať daný užívateľ prístup a môžete zvoliť či bude môcť iba čítať alebo aj robiť úpravy.

8. V ďalšom kroku dajte iba zvoliť ďalej. To sa Vás pýta iba, na ktorý zväzok. Ja mám 2 Zväzky. 4 T+ 4 T v RAID 1 a 1T + 1T v RAID 1. O RAID píšem viac v tu

9. V ďalšom kroku dávate užívateľovi prístup na aplikácie

10. V ďalšom kroku určujete užívateľovi obmedzenú rýchlosť. Ak to necháte na 0 tak bude mať neobmedzenú rýchlosť

11. Potvrďte nastavenia ak je všetko poriadku zvoľte Použiť. Užívateľ sa vytvorí za pár sekúnd

Ak máte hotového užívateľa, a ak máte vytvorený VPN klienta, tak môže pristupovať na NAS aj na diaľku. Ako Vytvoriť VPN certifikát nájdete tu

Vytvorenie VPN

Ak chcete pristupovať externe (mimo lokálnu sieť) na NAS, tak najbezpečnejšie riešenie je cez VPN. Na výber máte pri NAS 3 typy VPN.

  • PPTP
  • OpenVPN
  • L2TP/IPSec

Na Routri musíte, ako prvé povoliť službu port forwarding. Každý Router to má inak, tak na to žiaľ neexistuje univerzálny návod. Ja mám Router Asus RT-AC55U.

  1. Choďte do WAN
  2. Kliknite na Virtual Server / Port Forwarding
  • Servis Name nieje podstatný, dôležité je, aby ste vedeli na, ktorom porte počúva VPN k NAS

A zvoľte uložiť

V článku sa budeme venovať konfigurácií OpenVPN

  1. Keď idete tvoriť VPN na NAS tak si stiahnite aplikáciu VPN Server

2. Povoliť Server OpenVPN

  • Vypíšte port, na ktorom má počúvať OpenVPN
  • Povoliť kompresiu na licenciu VPN
  • Povoliť klientom prístup k sieti LAN (ak toto nepovolíte, tak síce VNP sa pripojí, ale bude Vám odmietať pripojenie sa na NAS)

3. Keď už máte hotové všetky kroky tak dajte Exportovať konfiguráciu

Súbor sa Vám stiahne v rare

Hlavný súbor je VPNConfig.ovpn

Tam si musíte zapísať, už len Verejnú IP adresu, ktorú Vám pridelil poskytovateľ internetu

Keď to uložíte, tak tento certifikát môžete posunúť užívateľom, ktorím chcete dať prístup na NAS.

V tomto kroku, musíte vytvoriť užívateľov na Servery. Ako nájdete v manuály Pridávanie užívateľov a ich práva